We have identified a call connection issue affecting multiple platforms. The issue has now been resolved and we are now seeing services operate at normal levels.
Please reach out to your service provider support team if you are experiencing any further issues.
Incident start time: 12:15 BST, 7th of August 2026 Incident end time: 14:30 BST, 7th of August 2026
Posted Aug 07, 2026 - 16:44 UTC
Monitoring
We believe we have identified the root cause and resolved it.
Posted Aug 07, 2026 - 13:45 UTC
Investigating
We are aware of an issue affecting calls through Anywhere365, which is resulting in call failures.
We are investigating internally and have escalated with Anywhere365 as a priority.
Our monitoring indicates that this issue started at 12:30GMT.
We will share updates hourly or when there is a significant update"
This incident affected: APAC (Multi-Cloud Contact Center Access (MCCA)), AMER (Multi-Cloud Contact Center Access (MCCA)), and EMEA (Multi-Cloud Contact Center Access (MCCA)).