Global incident - Call connection issues

Incident Report for HALO

Resolved

We are confident the issue has been resolved and the incident window is accurate. Please reach out to your service provider support team if you are experiencing any further issues.

Incident start time: 12:15 BST, 7th of August 2026
Incident end time: 14:30 BST, 7th of August 2026
Posted Aug 07, 2026 - 16:43 UTC

Monitoring

We have identified a call connection issue affecting multiple platforms. The issue has now been resolved and we are now seeing services operate at normal levels.

Please reach out to your service provider support team if you are experiencing any further issues.

Incident start time: 12:15 BST, 7th of August 2026
Incident end time: 14:30 BST, 7th of August 2026
Posted Aug 07, 2026 - 13:57 UTC